wi-fi

не подключается
Igor-ori
Igor-ori
  • Сообщений: 4
  • Последний визит:
    2 марта 2021 в 21:25
Я новичок, недавно установил Mint 19.2 Проблема подключения по вай-фай. подключение только по оптиволокну, по вай-фай роутер видит, предлагает подключиться, но каждый раз требует авторизации хотя пароль введён правильно. Эта тема уже была поднята Анжелой. Я внимательно почитал, посмотрел рекомендованный ролик: товарищ там объяснил вроде понятно, но команды, которые он вводил в терминале не рассмотреть. Так же другим товарищем была рекомендация установить менеджер сетевых подключений. Попытался по подсказке, но по моему не получилось (или я его не найду)… Другие гаджеты (два смартфона на андройде и бук с ХР подключаются влет… Каких настроек не хватает? Подскажите, будьте любезны smile
УЧЕНИК
УЧЕНИК
  • Сообщений: 43
  • Последний визит:
    10 августа 2021 в 16:04
Посмотрите здесь всё подробно по подключению
https://losst.ru/nasrojka-wifi-v-ubuntu
Редактировалось: 1 раз (Последний: 15 ноября 2021 в 19:26)
Igor-ori
Igor-ori
  • Сообщений: 4
  • Последний визит:
    2 марта 2021 в 21:25
Да подробно, но у меня на третьем шаге подключения через терминал (я выбрал этот раздел т.к. сеть у меня определяется, значит драйвера есть) он мне пишет: invalid option — w… и далее все по списку мне как барану на новые ворота… то же самое и с драйвером nl80211
igor@igor-Satellite-L40:~$ sudo wpa_supplicant -Dwext -wlp2s0 -cwpa.conf
wpa_supplicant: invalid option — 'w'
wpa_supplicant v2.6
Copyright © 2003-2016, Jouni Malinen <j@w1.fi> and contributors

This software may be distributed under the terms of the BSD license.
See README for more details.

This product includes software developed by the OpenSSL Project
for use in the OpenSSL Toolkit (http://www.openssl.org/)

usage:
wpa_supplicant [-BddhKLqqstuvW] [-P] [-g] \
[-G] \
-i-c[-C] [-D] [-p<driver_param>] \
[-b<br_ifname>] [-e] [-f] \
[-o] [-O] \
[-N -i-c[-C] [-D] \
[-m] \
[-p<driver_param>] [-b<br_ifname>] [-I] ...]

drivers:
nl80211 = Linux nl80211/cfg80211
wext = Linux wireless extensions (generic)
wired = Wired Ethernet driver
none = no driver (RADIUS server/WPS ER)
options:
-b = optional bridge interface name
-B = run daemon in the background
-c = Configuration file
-C = ctrl_interface parameter (only used if -c is not)
-d = increase debugging verbosity (-dd even more)
-D = driver name (can be multiple drivers: nl80211,wext)
-e = entropy file
-f = log output to debug file instead of stdout
-g = global ctrl_interface
-G = global ctrl_interface group
-h = show this help text
-i = interface name
-I = additional configuration file
-K = include keys (passwords, etc.) in debug output
-L = show license (BSD)
-m = Configuration file for the P2P Device interface
-N = start describing new interface
-o = override driver parameter for new interfaces
-O = override ctrl_interface parameter for new interfaces
-p = driver parameters
-P = PID file
-q = decrease debugging verbosity (-qq even less)
-s = log output to syslog instead of stdout
-t = include timestamp in debug messages
-T = record to Linux tracing in addition to logging
(records all messages regardless of debug verbosity)
-u = enable DBus control interface
-v = show version
-W = wait for a control interface monitor before starting
example:
wpa_supplicant -Dnl80211 -iwlan0 -c/etc/wpa_supplicant.conf
… и чего он хочет? и что делать дальше?..
УЧЕНИК
УЧЕНИК
  • Сообщений: 43
  • Последний визит:
    10 августа 2021 в 16:04
Igor-ori, Попробуйте убрать букву "w" в первом параметре после "-" и повторите ввод команды (проверьте имя драйвера в первом параметре).
Используйте пример команды указанный выше после example:
Редактировалось: 1 раз (Последний: 2 марта 2021 в 07:00)
Igor-ori
Igor-ori
  • Сообщений: 4
  • Последний визит:
    2 марта 2021 в 21:25
… снова перепробовал кучу вариантов. непротык. теперь не читаются «хвосты»… я писал команды, как рекомендовано на сайте. Там происходит успешное подключение(даже мне дилетанту это понятно) а у меня нет. Вот примеры:
wpa_supplicant -Dnl80211 -iwlan0 -c/etc/wpa_supplicant.conf
igor@igor-Satellite-L40:~$ wpa_supplicant -Dnl80211 -wlp2s0 -c/etc/wpa_supplicant.conf
wpa_supplicant: invalid option — 'w'
wpa_supplicant v2.6

wpa_supplicant -Dnl80211 -iwlan0 -c/etc/wpa_supplicant.conf
igor@igor-Satellite-L40:~$ wpa_supplicant -Dnl80211 -wlp2s0 -c/etc/wpa_supplicant.conf
wpa_supplicant: invalid option — 'w'
wpa_supplicant v2.6

wpa_supplicant -Dnl80211 -iwlan0 -c/etc/wpa_supplicant.conf
igor@igor-Satellite-L40:~$ pa_supplicant -Dnl80211 -wlp2s0 -c/etc/wpa_supplicant.conf

Command 'pa_supplicant' not found, did you mean:

command 'wpa_supplicant' from deb wpasupplicant

Try: sudo apt install igor@igor-Satellite-L40:~$ sudo wpa_supplicant -Dnl80211 -wlp2s0 -c/etc/wpa_supplicant.conf
[sudo] password for igor:
wpa_supplicant: invalid option — 'w'
wpa_supplicant v2.6

sudo wpa_supplicant -Dnl80211 -wlp2s0 -cpa.conf
wpa_supplicant: invalid option — 'w'
wpa_supplicant v2.6

igor@igor-Satellite-L40:~$ sudo wpa_supplicant -Dnl80211 -iwlan0 -c/etc/wpa_supplicant.conf
Successfully initialized wpa_supplicant
Failed to open config file '/etc/wpa_supplicant.conf', error: No such file or directory
Failed to read or parse configuration '/etc/wpa_supplicant.conf'.
igor@igor-Satellite-L40:~$ sudo wpa_supplicant -Dnl80211 -iwlp2s0 -cwlp.conf
Successfully initialized wpa_supplicant
Failed to open config file '/home/igor/wlp.conf', error: No such file or directory
Failed to read or parse configuration '/home/igor/wlp.conf'.
igor@igor-Satellite-L40:~$

перестал писать про w после того, как я добавил к интерфейсу i это было в формуле. Моя невнимательность. но почему-то не видит файла соединения… снова чего-то не догоняю… может быть нужно где-то что-то еще создать? в «учебнике» этого я не нашел… если создать, то в каком формате и где?
УЧЕНИК
УЧЕНИК
  • Сообщений: 43
  • Последний визит:
    10 августа 2021 в 16:04
Зайдите в BIOS, проверьте адаптер wi-fi, может отключен. В Synaptic в поле поиска введите wi-fi, возможно надо установить драйвера и библиотеки для вашей модели адаптера.
Попробуйте в окне Сетевые соединения создать новое соединение выбрать тип соединения Wi-Fi.Попробуйте не указывать в параметрах команд терминала букву w, может причина в этой букве.
Редактировалось: 2 раза (Последний: 3 марта 2021 в 09:44)
Stepan
Stepan
  • Сообщений: 1
  • Последний визит:
    25 октября 2021 в 14:52
Попробуйте установить последнюю версию — в ней улучшена поддержка wi-fi оборудования (у меня, например минт раньше его вообще не видел)
Вы не можете участвовать в этом разделе форума.
Войдите или зарегистрируйтесь, чтобы писать на форуме